Difference between revisions of "Packages forcing gcc use"

From Wiki [en] OpenMandriva
Jump to: navigation, search
m (add squashfs-tools)
m (add boost)
Line 69: Line 69:
  
 
many undefined refetences...
 
many undefined refetences...
 +
 +
== boost ==
 +
https://abf.io/openmandriva/boost

Revision as of 21:56, 5 February 2015

The following packages are currently forcing the compiler to be gcc (even if clang is the default compiler):

rpm

Uses nested functions heavily

glibc

Various gcc-isms

elfutils

make uses of nested fuctions

void foo() {

     void bar() {

     }

}

libvpx

ASM specific code to gcc

phonon

Extra clang flags fails to build

webkit

firefox

thunderbird

libqaccessibilityclient

anthy

https://abf.io/openmandriva/anthy

afpfs-ng

https://abf.io/openmandriva/afpfs-ng

aqemu

https://abf.io/openmandriva/aqemu

armagetron

https://abf.io/openmandriva/armagetron

audit

https://abf.io/openmandriva/audit

(Bero tried to patch the nested gcc not so much builds.Sflo)

k3b

https://abf.io/openmandriva/k3b nested functions

syncevolution

https://abf.rosalinux.ru/openmandriva/syncevolution

squashfs-tools

https://abf.io/openmandriva/squashfs-tools

many undefined refetences...

boost

https://abf.io/openmandriva/boost